NHS - Switch Issue

Incident Report for Technology Services

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 15:31 CST

Investigating

We currently investigating switch issues at NHS that are causing some network outages. We will provide updates when we can.
Posted Feb 09, 2026 - 14:45 CST
This incident affected: Infrastructure Systems and Services (Campus Network Services).