NHS - WAN Outage

Incident Report for Technology Services

Resolved

Issue has been identified. NHS is back online.
Posted Nov 06, 2025 - 12:21 CST

Investigating

Northwest HS is experiencing a connectivity outage. We are investigating the issue.
Posted Nov 06, 2025 - 10:13 CST
This incident affected: Infrastructure Systems and Services (Campus Network Services).