Infinite Campus Outage

Incident Report for Technology Services

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 09:04 CST

Investigating

Infinite Campus is currently experiencing an outage. We will update you as we get them.
Posted Oct 16, 2025 - 08:43 CST
This incident affected: Enterprise Business Applications (Infinite Campus).