Infinite Campus - Partial Outages

Incident Report for Technology Services

Resolved

IC appears to have solved the issue.
Posted Aug 24, 2026 - 09:58 CST

Investigating

Infinite Campus is currently experiencing intermittent outages across multiple districts. We will update you as we get them.
Posted Aug 24, 2026 - 07:37 CST
This incident affected: Enterprise Business Applications (Infinite Campus).