Network Communication Issues

Incident Report for Technology Services

Resolved

We have resolved issue and all services are back online.
Posted Aug 03, 2026 - 06:31 CST

Investigating

We may be experiencing district wide network communication issues. We are currently investigating the cause.
Posted Aug 03, 2026 - 05:06 CST
This incident affected: Infrastructure Systems and Services (Data Center Services, Firewall Services, Fiber Network Connectivity (WAN)).