Infinite Campus Issue

Incident Report for Technology Services

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 08:25 CST

Update

We are continuing to work on a fix for this issue.
Posted Sep 14, 2026 - 08:25 CST

Identified

Infinite Campus is having an issue this morning. We will provice updates as we get them.
Posted Sep 14, 2026 - 07:13 CST
This incident affected: Enterprise Business Applications (Infinite Campus).