Northwest HS - Network Outage

Incident Report for Technology Services

Update

We are continuing to monitor for any further issues.
Posted Oct 23, 2025 - 12:25 CST

Monitoring

Northwest HS is back online. We will continue to monitor the connection.
Posted Oct 23, 2025 - 12:24 CST

Investigating

Northwest HS is curretnly experiencing a network outage.
Posted Oct 23, 2025 - 09:19 CST
This incident affects: Infrastructure Systems and Services (Campus Network Services).