Windows Mobile Devices - Wireless Connectivity

Incident Report for Technology Services

Resolved

This issue has been resolved. Windows laptops can now connect to NWSD-NET.
Posted Nov 04, 2025 - 09:57 CST

Investigating

This is to inform you that we are experiencing an issue with Windows laptops connecting to NWSD-NET. CB and Apple devices are working normally. We will provide updates as soon as available.
Posted Nov 04, 2025 - 09:00 CST
This incident affected: Infrastructure Systems and Services (Wireless Network Services - WiFi).